突然消失するかもしれないブログ

”とつきえブログ”

squid-3.0.STABLE1にバージョンアップすると出るエラー

squid-2.6.STABLE16からsquid-3.0.STABLE1にバージョンアップしたところ、”acl all”に関する定義を削除するようにwarningが出るようになってしまいました。

調べてみると、以下の通り、squid-3.xになってから、”acl all”の定義がデフォルトでsquidに組み込まれたためsquid.confに定義しなくても使えるようになったとのこと。ということで、squid.confから”acl all”の定義を削除したらwarningが出なくなりました。

http://www.mail-archive.com/squid-users@squid-cache.org/msg52163.html

2008/01/18 08:27:23| WARNING: ‘0.0.0.0/0.0.0.0’ is a subnetwork of ‘0.0.0.0/0.0.0.0’ 2008/01/18 08:27:23| WARNING: because of this ‘0.0.0.0/0.0.0.0’ is ignored to keep splay tree searching predictable 2008/01/18 08:27:23| WARNING: You should probably remove ‘0.0.0.0/0.0.0.0’ from the ACL named ‘all’


You are using 3.x yes? ‘all’ ACL has been made a built-in ACL now for 3.1 and some earlier. You can remove it from your squid.conf file.

それと、”broken_vary_encoding”という定義も無くなったようなので削除したらwarningが出なくなりました。良くわかりませんがとりあえず動いているようなのでめでたしめでたし?

squid-3.0.STABLE1にバージョンアップすると出るエラー」への1件のフィードバック

  1. Caroline 1月 2, 2015 3:04 pm

    AFAIC tht’as the best answer so far!

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中

%d人のブロガーが「いいね」をつけました。